[TxMt] Re: "Half focused" windows bug

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[TxMt] Re: "Half focused" windows bug

Graham Heath
Hello Ed, All,

None of my previous theories worked out, but I think I’ve had a break through on this.

I can trivially reproduce it now by switching between iTerm2 and TextMate, very quickly. Finder might work too, but I’ve been using iTerm. The key seems to have less to do with which app, and more to do with how fast. My machine is slow which may make the problem worse.

What I do know is if I reset my configs to their defaults (by removing ~/Library/Application Support/TextMate), this problem is eliminated. Adding folders back one at a time TextMate still works until I add the Session/Info.plist back.

I’ve attached my info.plst and made a video of what I see while I’m working on this; https://youtu.be/C0nyIr5_dTQ

Ed, does removing this file do anything for you?

Everyone; Does this make any sense? Does anyone know where to begin solving this bug? I sure don’t.

Thanks,

Graham Heath


On February 15, 2017 at 7:48:39 AM, Ed Wong ([hidden email]) wrote:

Graham, I don’t have Diff Gutter enabled, just the standard line numbers, folding arrows, bookmarks in the gutter.

Ed


On 14 Feb2017, at 3:56 PM, Graham Heath <[hidden email]> wrote:

Thanks for the answers. What all is happening here is still a mystery but I’ve got an update;

I’ve now had 24 hours without incident. My current theory is this relates to SCM Diff Gutter, as after disabling it I haven’t seen the issue, but thats just a theory. I’m re-enabling Emmet today, and I’ll add my linters tomorrow.

Ed, do you have SCM Diff Gutter, or anything adding icons to your gutter?

Thanks,

Graham Heath


On February 10, 2017 at 9:08:03 PM, Ed Wong ([hidden email]) wrote:

1: have more than a few TextMate windows or tabs open?

Usually many windows with many tabs. Some windows are minimized (those that I’m not actively working on at the moment).

2: have a customized window bar title?

Yes - full document path.

3: have expensive to render documents?

A few files with > 5000 lines but generally < 1500 lines of PHP, ObjC, HTML, JS or CSS. Some customizations done to PHP bundle and Mac Classic theme.

4: SCM integration?

Git on some projects.

Hope this helps.

Ed


On Feb 10, 2017, at 5:33 PM, Graham Heath <[hidden email]> wrote:

This continues to happen to me a few times a day, exclusively in TextMate. Some days are worse, maybe better after a reboot, but thats not for sure.

Some more theories for you Ed, and anyone else :)

Do you …
1: have more than a few TextMate windows or tabs open?
2: have a customized window bar title?
3: have expensive to render documents?
4: SCM integration?


Here’s what I’m thinking _might_ be happening for each of these. Hopefully one of these sparkles for someone.

1) TM is confused about what tab / window should have focus, and fails to pick one.
2) I have a pretty complex stack of replacements to build my window title, perhaps one of these replacements has a edge case that causes an error
3) TM may be selecting the right tab, but the selection doesn’t happen in a reasonable time and aborts
4) The timing between focus and TM failing to select a tab seems related to when the title bar updates when SCM is working

I’ve been experimenting with disabling plugins and add ons. Today I’m going to try disabling the SCM plugin :( 

If that doesn’t work I guess I’ll build TM and see what I can find. Short of building it, there’s not a way better debug this issue, is there?

Thanks,

Graham Heath


On February 1, 2017 at 7:05:23 AM, Ed Wong ([hidden email]) wrote:

Hi Graham,

My TM setup is pretty basic. No plug-ins, Shell Support installed, Git support sometimes depending on the project. 

I think Allan may be right though as I’ve seen this behaviour with Safari and Finder as well so it could be an general OS issue.

Ed

On Jan 31, 2017, at 10:23 PM, Graham Heath <[hidden email]> wrote:

Allan, I’m sorry to say, that this is behavior that I associate with TextMate, not the os at large. I will keep an eye out for it and let you know if I change my mind. But, as you’ll see below, I don’t really blame your code either, I’m just wondering whats causing it. Its so erratic that its probably not something simple.

Jacob, Ed, and others; Do you have any plugins? I haven’t done the full reset, but I have disabled things that I feel might be offending. Its too early to say, but I wonder if a plugin might be triggering when the app gets focus, but something isn’t going quite right.

Tossing this on the pile; I’m using a early 2013 mbp that does seem to have issues with apps hanging or freezing fairly often, so maybe whatever’s causing that, is causing this.

Thanks,

Graham Heath


On January 14, 2017 at 11:44:42 PM, Allan Odgaard ([hidden email]) wrote:

On 14 Jan 2017, at 5:54, Graham Heath wrote:

> I’m regularly experiencing a bug where TextMate seems to receive 
> partial
> focus. The title bar will appear to be selected, but the tabs never 
> come
> into focus […]

This issue has existed with macOS for as long as I can remember, and I 
have seen it for other apps as well, though it is visually much more 
obvious with TextMate because of the tabs bleeding into the title bar.

I do not think the issue is with any of my code, since window management 
is not the responsibility of the individual app and I am not aware of 
code in TextMate that could affect this.

_______________________________________________
textmate mailing list
[hidden email]
http://lists.macromates.com/listinfo/textmate

_______________________________________________
textmate mailing list
[hidden email]
http://lists.macromates.com/listinfo/textmate


_______________________________________________ 
textmate mailing list 
[hidden email] 
http://lists.macromates.com/listinfo/textmate



_______________________________________________
textmate mailing list
[hidden email]
http://lists.macromates.com/listinfo/textmate

Info.plist.zip (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[TxMt] Re: "Half focused" windows bug

dangerwillrobinsondanger
I had this for ages and it was frustrating.
I did isolate it by reducing the number of Bundles enabled, severely.
I enabled have less than half of the bundles that TextMate actively knows of.
The cause is absolutely in a bundle, but I do not know which one.



On Mar 2, 2017, at 11:15, Graham Heath <[hidden email]> wrote:

Hello Ed, All,

None of my previous theories worked out, but I think I’ve had a break through on this.

I can trivially reproduce it now by switching between iTerm2 and TextMate, very quickly. Finder might work too, but I’ve been using iTerm. The key seems to have less to do with which app, and more to do with how fast. My machine is slow which may make the problem worse.

What I do know is if I reset my configs to their defaults (by removing ~/Library/Application Support/TextMate), this problem is eliminated. Adding folders back one at a time TextMate still works until I add the Session/Info.plist back.

I’ve attached my info.plst and made a video of what I see while I’m working on this; https://youtu.be/C0nyIr5_dTQ

Ed, does removing this file do anything for you?

Everyone; Does this make any sense? Does anyone know where to begin solving this bug? I sure don’t.

Thanks,

Graham Heath


On February 15, 2017 at 7:48:39 AM, Ed Wong ([hidden email]) wrote:

Graham, I don’t have Diff Gutter enabled, just the standard line numbers, folding arrows, bookmarks in the gutter.

Ed


On 14 Feb2017, at 3:56 PM, Graham Heath <[hidden email]> wrote:

Thanks for the answers. What all is happening here is still a mystery but I’ve got an update;

I’ve now had 24 hours without incident. My current theory is this relates to SCM Diff Gutter, as after disabling it I haven’t seen the issue, but thats just a theory. I’m re-enabling Emmet today, and I’ll add my linters tomorrow.

Ed, do you have SCM Diff Gutter, or anything adding icons to your gutter?

Thanks,

Graham Heath


On February 10, 2017 at 9:08:03 PM, Ed Wong ([hidden email]) wrote:

1: have more than a few TextMate windows or tabs open?

Usually many windows with many tabs. Some windows are minimized (those that I’m not actively working on at the moment).

2: have a customized window bar title?

Yes - full document path.

3: have expensive to render documents?

A few files with > 5000 lines but generally < 1500 lines of PHP, ObjC, HTML, JS or CSS. Some customizations done to PHP bundle and Mac Classic theme.

4: SCM integration?

Git on some projects.

Hope this helps.

Ed


On Feb 10, 2017, at 5:33 PM, Graham Heath <[hidden email]> wrote:

This continues to happen to me a few times a day, exclusively in TextMate. Some days are worse, maybe better after a reboot, but thats not for sure.

Some more theories for you Ed, and anyone else :)

Do you …
1: have more than a few TextMate windows or tabs open?
2: have a customized window bar title?
3: have expensive to render documents?
4: SCM integration?


Here’s what I’m thinking _might_ be happening for each of these. Hopefully one of these sparkles for someone.

1) TM is confused about what tab / window should have focus, and fails to pick one.
2) I have a pretty complex stack of replacements to build my window title, perhaps one of these replacements has a edge case that causes an error
3) TM may be selecting the right tab, but the selection doesn’t happen in a reasonable time and aborts
4) The timing between focus and TM failing to select a tab seems related to when the title bar updates when SCM is working

I’ve been experimenting with disabling plugins and add ons. Today I’m going to try disabling the SCM plugin :( 

If that doesn’t work I guess I’ll build TM and see what I can find. Short of building it, there’s not a way better debug this issue, is there?

Thanks,

Graham Heath


On February 1, 2017 at 7:05:23 AM, Ed Wong ([hidden email]) wrote:

Hi Graham,

My TM setup is pretty basic. No plug-ins, Shell Support installed, Git support sometimes depending on the project. 

I think Allan may be right though as I’ve seen this behaviour with Safari and Finder as well so it could be an general OS issue.

Ed

On Jan 31, 2017, at 10:23 PM, Graham Heath <[hidden email]> wrote:

Allan, I’m sorry to say, that this is behavior that I associate with TextMate, not the os at large. I will keep an eye out for it and let you know if I change my mind. But, as you’ll see below, I don’t really blame your code either, I’m just wondering whats causing it. Its so erratic that its probably not something simple.

Jacob, Ed, and others; Do you have any plugins? I haven’t done the full reset, but I have disabled things that I feel might be offending. Its too early to say, but I wonder if a plugin might be triggering when the app gets focus, but something isn’t going quite right.

Tossing this on the pile; I’m using a early 2013 mbp that does seem to have issues with apps hanging or freezing fairly often, so maybe whatever’s causing that, is causing this.

Thanks,

Graham Heath


On January 14, 2017 at 11:44:42 PM, Allan Odgaard ([hidden email]) wrote:

On 14 Jan 2017, at 5:54, Graham Heath wrote:

> I’m regularly experiencing a bug where TextMate seems to receive 
> partial
> focus. The title bar will appear to be selected, but the tabs never 
> come
> into focus […]

This issue has existed with macOS for as long as I can remember, and I 
have seen it for other apps as well, though it is visually much more 
obvious with TextMate because of the tabs bleeding into the title bar.

I do not think the issue is with any of my code, since window management 
is not the responsibility of the individual app and I am not aware of 
code in TextMate that could affect this.





_______________________________________________
textmate mailing list
[hidden email]
http://lists.macromates.com/listinfo/textmate
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[TxMt] Re: "Half focused" windows bug

Ed Wong-3
In reply to this post by Graham Heath
Hi Graham, 

I can’t reliably reproduce it so I don’t think my use cases are going to be any help. For instance I haven’t experienced this problem in a few weeks because it shows up sporadically for me, not enough to be a major nuisance. But it is annoying when it happens and I start typing and nothing shows. :-)

Times I’ve seen it happen is when I have a lot of files open in one window (> 30) with some of them extremely large files so it could be a speed issue as you’ve mentioned in the past. My main level machine is a vintage 2011 MBP but I’ve upgraded it with a 1TB SDD so it’s not too bad, just the CPU is showing it’s age at times. The other one is a recent MBA and I’ve never had it happen on that one.

Ed


On 1 Mar2017, at 9:15 PM, Graham Heath <[hidden email]> wrote:

Hello Ed, All,

None of my previous theories worked out, but I think I’ve had a break through on this.

I can trivially reproduce it now by switching between iTerm2 and TextMate, very quickly. Finder might work too, but I’ve been using iTerm. The key seems to have less to do with which app, and more to do with how fast. My machine is slow which may make the problem worse.

What I do know is if I reset my configs to their defaults (by removing ~/Library/Application Support/TextMate), this problem is eliminated. Adding folders back one at a time TextMate still works until I add the Session/Info.plist back.

I’ve attached my info.plst and made a video of what I see while I’m working on this; https://youtu.be/C0nyIr5_dTQ

Ed, does removing this file do anything for you?

Everyone; Does this make any sense? Does anyone know where to begin solving this bug? I sure don’t.

Thanks,

Graham Heath


On February 15, 2017 at 7:48:39 AM, Ed Wong ([hidden email]) wrote:

Graham, I don’t have Diff Gutter enabled, just the standard line numbers, folding arrows, bookmarks in the gutter.

Ed


On 14 Feb2017, at 3:56 PM, Graham Heath <[hidden email]> wrote:

Thanks for the answers. What all is happening here is still a mystery but I’ve got an update;

I’ve now had 24 hours without incident. My current theory is this relates to SCM Diff Gutter, as after disabling it I haven’t seen the issue, but thats just a theory. I’m re-enabling Emmet today, and I’ll add my linters tomorrow.

Ed, do you have SCM Diff Gutter, or anything adding icons to your gutter?

Thanks,

Graham Heath


On February 10, 2017 at 9:08:03 PM, Ed Wong ([hidden email]) wrote:

1: have more than a few TextMate windows or tabs open?

Usually many windows with many tabs. Some windows are minimized (those that I’m not actively working on at the moment).

2: have a customized window bar title?

Yes - full document path.

3: have expensive to render documents?

A few files with > 5000 lines but generally < 1500 lines of PHP, ObjC, HTML, JS or CSS. Some customizations done to PHP bundle and Mac Classic theme.

4: SCM integration?

Git on some projects.

Hope this helps.

Ed


On Feb 10, 2017, at 5:33 PM, Graham Heath <[hidden email]> wrote:

This continues to happen to me a few times a day, exclusively in TextMate. Some days are worse, maybe better after a reboot, but thats not for sure.

Some more theories for you Ed, and anyone else :)

Do you …
1: have more than a few TextMate windows or tabs open?
2: have a customized window bar title?
3: have expensive to render documents?
4: SCM integration?


Here’s what I’m thinking _might_ be happening for each of these. Hopefully one of these sparkles for someone.

1) TM is confused about what tab / window should have focus, and fails to pick one.
2) I have a pretty complex stack of replacements to build my window title, perhaps one of these replacements has a edge case that causes an error
3) TM may be selecting the right tab, but the selection doesn’t happen in a reasonable time and aborts
4) The timing between focus and TM failing to select a tab seems related to when the title bar updates when SCM is working

I’ve been experimenting with disabling plugins and add ons. Today I’m going to try disabling the SCM plugin :( 

If that doesn’t work I guess I’ll build TM and see what I can find. Short of building it, there’s not a way better debug this issue, is there?

Thanks,

Graham Heath


On February 1, 2017 at 7:05:23 AM, Ed Wong ([hidden email]) wrote:

Hi Graham,

My TM setup is pretty basic. No plug-ins, Shell Support installed, Git support sometimes depending on the project. 

I think Allan may be right though as I’ve seen this behaviour with Safari and Finder as well so it could be an general OS issue.

Ed

On Jan 31, 2017, at 10:23 PM, Graham Heath <[hidden email]> wrote:

Allan, I’m sorry to say, that this is behavior that I associate with TextMate, not the os at large. I will keep an eye out for it and let you know if I change my mind. But, as you’ll see below, I don’t really blame your code either, I’m just wondering whats causing it. Its so erratic that its probably not something simple.

Jacob, Ed, and others; Do you have any plugins? I haven’t done the full reset, but I have disabled things that I feel might be offending. Its too early to say, but I wonder if a plugin might be triggering when the app gets focus, but something isn’t going quite right.

Tossing this on the pile; I’m using a early 2013 mbp that does seem to have issues with apps hanging or freezing fairly often, so maybe whatever’s causing that, is causing this.

Thanks,

Graham Heath


On January 14, 2017 at 11:44:42 PM, Allan Odgaard ([hidden email]) wrote:

On 14 Jan 2017, at 5:54, Graham Heath wrote:

> I’m regularly experiencing a bug where TextMate seems to receive 
> partial
> focus. The title bar will appear to be selected, but the tabs never 
> come
> into focus […]

This issue has existed with macOS for as long as I can remember, and I 
have seen it for other apps as well, though it is visually much more 
obvious with TextMate because of the tabs bleeding into the title bar.

I do not think the issue is with any of my code, since window management 
is not the responsibility of the individual app and I am not aware of 
code in TextMate that could affect this.

_______________________________________________
textmate mailing list
[hidden email]
http://lists.macromates.com/listinfo/textmate

_______________________________________________
textmate mailing list
[hidden email]
http://lists.macromates.com/listinfo/textmate


_______________________________________________ 
textmate mailing list 
[hidden email] 
http://lists.macromates.com/listinfo/textmate

<Info.plist.zip>



_______________________________________________
textmate mailing list
[hidden email]
http://lists.macromates.com/listinfo/textmate
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[TxMt] Re: "Half focused" windows bug

Graham Heath
Hello again, 

Unfortunately my previous letter's solution is not much of a solution. It's only temporary and, in retrospect, I’m not even sure its more effective than quitting and relaunching TextMate. I must have tried that at the time, but I don’t recall doing so.

I’m back to basics, disabling and re-enabling bundles on whims. 

This time around I’m suspicious of the machine itself. It seems odd to me that sometimes even the most minor changes in a small text file can cause my TextMate to hang for up to 6 or 7 seconds. It seems like if I switch from and back to TextMate while its saving I frequently get the "half focus" state to reproduce. Does this sound familiar?

Ed, and anyone else interested, are you using the Save On Focus Lost bundle? Or something another bundle that has a command thats triggered on "callback.application.did-deactivate"?

What about .bash_profile, could introducing a delay there be causing the delay on save?

And finally; 

Is there a chance that TextMate and my development scripts (gulp w/ file monitoring and lots of tasks) are introducing some sort of file lock, that TextMate is failing to resolve?

I’ll work to answer these questions on my own, but I’m concerned (and optimistic) that I’ll no longer be able to reproduce these issues when I upgrade to my new machine.

Thanks,

Graham Heath


On March 2, 2017 at 9:14:30 AM, Ed Wong ([hidden email]) wrote:

Hi Graham, 

I can’t reliably reproduce it so I don’t think my use cases are going to be any help. For instance I haven’t experienced this problem in a few weeks because it shows up sporadically for me, not enough to be a major nuisance. But it is annoying when it happens and I start typing and nothing shows. :-)

Times I’ve seen it happen is when I have a lot of files open in one window (> 30) with some of them extremely large files so it could be a speed issue as you’ve mentioned in the past. My main level machine is a vintage 2011 MBP but I’ve upgraded it with a 1TB SDD so it’s not too bad, just the CPU is showing it’s age at times. The other one is a recent MBA and I’ve never had it happen on that one.

Ed


On 1 Mar2017, at 9:15 PM, Graham Heath <[hidden email]> wrote:

Hello Ed, All,

None of my previous theories worked out, but I think I’ve had a break through on this.

I can trivially reproduce it now by switching between iTerm2 and TextMate, very quickly. Finder might work too, but I’ve been using iTerm. The key seems to have less to do with which app, and more to do with how fast. My machine is slow which may make the problem worse.

What I do know is if I reset my configs to their defaults (by removing ~/Library/Application Support/TextMate), this problem is eliminated. Adding folders back one at a time TextMate still works until I add the Session/Info.plist back.

I’ve attached my info.plst and made a video of what I see while I’m working on this; https://youtu.be/C0nyIr5_dTQ

Ed, does removing this file do anything for you?

Everyone; Does this make any sense? Does anyone know where to begin solving this bug? I sure don’t.

Thanks,

Graham Heath


On February 15, 2017 at 7:48:39 AM, Ed Wong ([hidden email]) wrote:

Graham, I don’t have Diff Gutter enabled, just the standard line numbers, folding arrows, bookmarks in the gutter.

Ed


On 14 Feb2017, at 3:56 PM, Graham Heath <[hidden email]> wrote:

Thanks for the answers. What all is happening here is still a mystery but I’ve got an update;

I’ve now had 24 hours without incident. My current theory is this relates to SCM Diff Gutter, as after disabling it I haven’t seen the issue, but thats just a theory. I’m re-enabling Emmet today, and I’ll add my linters tomorrow.

Ed, do you have SCM Diff Gutter, or anything adding icons to your gutter?

Thanks,

Graham Heath


On February 10, 2017 at 9:08:03 PM, Ed Wong ([hidden email]) wrote:

1: have more than a few TextMate windows or tabs open?

Usually many windows with many tabs. Some windows are minimized (those that I’m not actively working on at the moment).

2: have a customized window bar title?

Yes - full document path.

3: have expensive to render documents?

A few files with > 5000 lines but generally < 1500 lines of PHP, ObjC, HTML, JS or CSS. Some customizations done to PHP bundle and Mac Classic theme.

4: SCM integration?

Git on some projects.

Hope this helps.

Ed


On Feb 10, 2017, at 5:33 PM, Graham Heath <[hidden email]> wrote:

This continues to happen to me a few times a day, exclusively in TextMate. Some days are worse, maybe better after a reboot, but thats not for sure.

Some more theories for you Ed, and anyone else :)

Do you …
1: have more than a few TextMate windows or tabs open?
2: have a customized window bar title?
3: have expensive to render documents?
4: SCM integration?


Here’s what I’m thinking _might_ be happening for each of these. Hopefully one of these sparkles for someone.

1) TM is confused about what tab / window should have focus, and fails to pick one.
2) I have a pretty complex stack of replacements to build my window title, perhaps one of these replacements has a edge case that causes an error
3) TM may be selecting the right tab, but the selection doesn’t happen in a reasonable time and aborts
4) The timing between focus and TM failing to select a tab seems related to when the title bar updates when SCM is working

I’ve been experimenting with disabling plugins and add ons. Today I’m going to try disabling the SCM plugin :( 

If that doesn’t work I guess I’ll build TM and see what I can find. Short of building it, there’s not a way better debug this issue, is there?

Thanks,

Graham Heath


On February 1, 2017 at 7:05:23 AM, Ed Wong ([hidden email]) wrote:

Hi Graham,

My TM setup is pretty basic. No plug-ins, Shell Support installed, Git support sometimes depending on the project. 

I think Allan may be right though as I’ve seen this behaviour with Safari and Finder as well so it could be an general OS issue.

Ed

On Jan 31, 2017, at 10:23 PM, Graham Heath <[hidden email]> wrote:

Allan, I’m sorry to say, that this is behavior that I associate with TextMate, not the os at large. I will keep an eye out for it and let you know if I change my mind. But, as you’ll see below, I don’t really blame your code either, I’m just wondering whats causing it. Its so erratic that its probably not something simple.

Jacob, Ed, and others; Do you have any plugins? I haven’t done the full reset, but I have disabled things that I feel might be offending. Its too early to say, but I wonder if a plugin might be triggering when the app gets focus, but something isn’t going quite right.

Tossing this on the pile; I’m using a early 2013 mbp that does seem to have issues with apps hanging or freezing fairly often, so maybe whatever’s causing that, is causing this.

Thanks,

Graham Heath


On January 14, 2017 at 11:44:42 PM, Allan Odgaard ([hidden email]) wrote:

On 14 Jan 2017, at 5:54, Graham Heath wrote:

> I’m regularly experiencing a bug where TextMate seems to receive 
> partial
> focus. The title bar will appear to be selected, but the tabs never 
> come
> into focus […]

This issue has existed with macOS for as long as I can remember, and I 
have seen it for other apps as well, though it is visually much more 
obvious with TextMate because of the tabs bleeding into the title bar.

I do not think the issue is with any of my code, since window management 
is not the responsibility of the individual app and I am not aware of 
code in TextMate that could affect this.

_______________________________________________
textmate mailing list
[hidden email]
http://lists.macromates.com/listinfo/textmate

_______________________________________________
textmate mailing list
[hidden email]
http://lists.macromates.com/listinfo/textmate


_______________________________________________ 
textmate mailing list 
[hidden email] 
http://lists.macromates.com/listinfo/textmate

<Info.plist.zip>



_______________________________________________
textmate mailing list
[hidden email]
http://lists.macromates.com/listinfo/textmate
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[TxMt] Re: "Half focused" windows bug

Etienne Samson
Le 9 mars 2017 à 01:31, Graham Heath <[hidden email]> a écrit :

> It seems odd to me that sometimes even the most minor changes in a small text file can cause my TextMate to hang for up to 6 or 7 seconds. It seems like if I switch from and back to TextMate while its saving I frequently get the "half focus" state to reproduce. Does this sound familiar?

Yes. WindowServer is a piece of **it. I get that 6 to 7 delay almost all the time when switching from Chrome to TextMate, or the reverse.

** you can monitor it's CPU usage for a more definite proof. Mine has a tendency to jump around 50-70% when that happens, and there are many reports of something wonky going on in Apple forums.

It seems definitely related to the number of windows I have open, so closing some of those alleviate the issue. I'm not intimate with either Chrome or TextMate tab handling, but I suspect somehow one tab = one "window" (to the window server).

Regards,
Etienne Samson
--
[hidden email]

_______________________________________________
textmate mailing list
[hidden email]
http://lists.macromates.com/listinfo/textmate
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[TxMt] Re: "Half focused" windows bug

Ed Wong-3
In reply to this post by Graham Heath
Ed, and anyone else interested, are you using the Save On Focus Lost bundle? Or something another bundle that has a command thats triggered on "callback.application.did-deactivate"?


No, that would be all sorts of bad for me to have that turned on. :-) 

Ed


_______________________________________________
textmate mailing list
[hidden email]
http://lists.macromates.com/listinfo/textmate
Loading...