Insert Close Tag stopped working

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Insert Close Tag stopped working

Matt Neuburg
Something has gone wrong with the Insert Close Tag command. It puts up a dialog that says

    "This command requires OS X 10.9 or higher."

As I'm using OS X 10.14, that is a curious objection to make.

I can solve the problem by changing

    #!/usr/bin/env ruby20

to

    #!/usr/bin/env ruby

m.

--
matt neuburg, phd = http://www.apeth.net/matt/
pantes anthropoi tou eidenai oregontai phusei
Programming iOS 13! http://shop.oreilly.com/product/0636920310075.do
iOS 13 Fundamentals! http://shop.oreilly.com/product/0636920310068.do
RubyFrontier! http://www.apeth.com/RubyFrontierDocs/default.html


_______________________________________________
TextMate mailing list
[hidden email]
https://lists.macromates.com/listinfo/textmate
Reply | Threaded
Open this post in threaded view
|

Re: Insert Close Tag stopped working

Allan Odgaard-4

On 30 Oct 2019, at 0:36, Matt Neuburg wrote:

Something has gone wrong with the Insert Close Tag command. It puts up a dialog that says

"This command requires OS X 10.9 or higher."

As I'm using OS X 10.14, that is a curious objection to make.

The check is actually for ruby 2 being installed on your system, and if it is not found, it assumes you are not on OS X 10.9+.

Can you try to run this in a terminal:

ls -l /System/Library/Frameworks/Ruby.framework/Versions

Ideally it would show a version number >= 2.0.

If you do see a version then try this line:

ls -l /System/Library/Frameworks/Ruby.framework/Versions/2.*/usr/bin/ruby


_______________________________________________
TextMate mailing list
[hidden email]
https://lists.macromates.com/listinfo/textmate